Increased Latency within Nooks platform
Resolved·Degraded performance

Our engineering team has deployed improvements to address the recent latency issues, and platform performance has returned to normal. Thank you for your patience as we worked to resolve this.

Wed, Dec 10, 2025, 04:06 AM
(1 day ago)
·
Affected components
Dialer
Salesfloor
Integrations
Reporting
Updates

Resolved

Our engineering team has deployed improvements to address the recent latency issues, and platform performance has returned to normal. Thank you for your patience as we worked to resolve this.

Wed, Dec 10, 2025, 04:06 AM

Investigating

We have mitigated the issue of latency across Nooks and the platform is stable. Our engineering team is still investigating the root cause of this, and we will post additional updates here.

Wed, Dec 10, 2025, 12:11 AM(3 hours earlier)

Investigating

We are continuing to investigate intermittent latency affecting a subset of users. Thank you for your patience as we work to resolve this.

Tue, Dec 9, 2025, 09:27 PM(2 hours earlier)

Monitoring

Nooks engineers have identified what we believe to be the cause of the latency and have deployed a fix. We are seeing signs of recovery on the platform, and we'll continue to monitor the situation.

Tue, Dec 9, 2025, 08:45 PM(41 minutes earlier)

Investigating

We’re investigating increased latency within the Nooks platform. Our Engineering team is actively looking into this issue and monitoring performance. We’ll share updates as more information becomes available.

Tue, Dec 9, 2025, 08:26 PM(19 minutes earlier)